PixTOPO 操作マニュアル

PixTOPOの起動
Windowsのスタート・メニューから『PixTOPO』→『PixTOPO Ver.X.X』を選択してください。
■ファイル■
投影法の詳細については地図投影法の解説ページをご覧下さい。。 PixTOPOで標高データの表示やフォーマット変換を行う前に、データを表現する地図投影法を選択する必要があります。PixTOPOではUTM(ユニバーサル横メルカトル)図法、または公共測量座標系のどちらかを選択できます。
UTMゾーン UTM図法は日本の地形図で採用されている投影法であり、全世界を経度6度ごとに60のゾーンに分け、それぞれの中でゾーン中心を原点としたXY座標を求めます。

UTM図法を使うためには
、メニューの『ファイル』→『UTMゾーン』を選んでください。
図のような地図画面から、表示したいエリアが属するゾーンをマウス左クリックで選択してください。
測量座標系 公共測量座標系と呼ばれる日本独自の座標系を使うこともできます。この投影法では日本全域を19の座標系に分けることで、歪みを最小限に抑えることができます。

公共測量座標系を使うためには、メニューの『ファイル』→『座標系選択』を選んでください。
図のような地図画面が現れます。マウスで、データのエリアに最も近い原点を選択してください。
画面保存 現在表示されている画面をJPEG形式の画像ファイルとして保存します。
一時ファイル用パス PixTOPOは標高データの表示を高速化するため、CD-ROMのテキスト・ファイルを圧縮+座標変換した独自フォーマットのバイナリー・ファイルを生成します。メニューからこのバイナリー・ファイルを保存するディレクトリーを指定することもできます。
■平面表示■
50m

『平面表示』を行うためにははじめに、『ファイル』→『UTMゾーン』、または、『測量座標系』で投影法とパラメーターを選択しておく必要があります。
25000数値地図の標高データを平面的に表示します。ファイルを選択するダイアログが開き、表示する標高データを選択することができます。
50m間隔のファイルはMEMという拡張子が付いています。ファイルは同時に、縦横3面の範囲、最大で9面までを選択→表示できます。
250m/1km

『250mと1kmなど間隔の違うデータを混在させて選択することはできません
2個以上のデータを選択するには、一つ目を普通にマウスで選んだあと、2個目以降をキーボードのCtrlキーを押しながらクリックしてください
20万の標高データを平面的に表示します。ファイルを選択するダイアログが開き、表示する標高データを選択することができます。
250m、1km間隔のデータファイルはそれぞれSEMとTEMという拡張子を持っています。ファイルは同時に、縦横3面の範囲、最大で9面までを選択→表示できます。
火山 数値地図10mメッシュ(火山標高)のデータを平面的に表示します。ファイルを選択するダイアログが開き、表示する標高データを選択することができます。
【注意】このデータは、標高データ本体であるLEMと、ヘッダー情報であるCSVのふたつからなり、それぞれLEMとCSVと言うディレクトリーに分かれて納められています。ファイルをハード・ディスクなどにコピーする場合は、この相対的な位置関係を保つことが必要です。

例:ディレクトリー:c:\data\kazanにコピーする場合、*.lemファイルはc:\data\kazan\lem、*.csvファイルはc:\data\kazan\csvに保存してください。
ファイル・ダイアログより、lemファイルを選択してください。選択→表示できるのはひとつだけです。複数のファイルを同時に表示はできません。
表示パラメーター

シェーディングなし

シェーディングあり
下記の平面表示のパラメーターを選択できます。
海洋部分を表示 この項目をチェックすると海洋部分を指定した色で塗りつぶします
シェーディング 日照をシミュレートした陰影付けを行う場合はここをチェックします。
太陽方位 データ中心部から見た太陽位置を0〜360度の方位で設定します(真東=0°)。『シェーディング』がオンの場合のみ有効。
太陽高度 0〜90°の間で指定します。0=水平、90=真上に当たります『シェーディング』がオンの場合のみ有効。
表示間隔 デフォルトは1→すべての点を表示します。2以上の場合は格子の間隔を飛ばしながら荒い表示を行います
色分け 地形を標高、傾斜、斜面方位のどれに基づいて色分けするかを選択します
エリア指定 現在平面表示されている地域の中の一部を拡大して表示します。拡大する四角形エリアはマウスの左クリックで指定します。
全体表示 『エリア指定』して一部を拡大した後、選択したデータファイルの全域を表示しなおします。
■立体表示■
50m

『平面表示』を行うためにははじめに、『ファイル』→『UTMゾーン』、または、『測量座標系』で投影法とパラメーターを選択しておく必要があります。
25000の標高データを立体的に表示します。ファイルを選択するダイアログが開き、表示する標高データを選択することができます。
50m間隔のファイルはMEMという拡張子が付いています。ファイルは同時に、縦横3面の範囲、最大で9面までを選択→表示できます。
250m/1km

250m、1kmなど間隔の違うデータを混在させて選択することはできません
2の標高データを立体的に表示します。ファイルを選択するダイアログが開き、表示する標高データを選択することができます。
250m、1km間隔のデータファイルはそれぞれ、SEM、TEMという拡張子を持っています。ファイルは同時に、縦横3面の範囲、最大で9面までを選択→表示できます。
50m 数値地図

『平面表示』を行うためにははじめに、『ファイル』→『UTMゾーン』、または、『測量座標系』で投影法とパラメーターを選択しておく必要があります。
CD-ROMで供給されている25000、20万の地形図画像を標高データの上に貼り付けた『立体地形図』を作成することができます。
立体的に表示された25000の標高データの上に地図画像を重ねます。
はじめにファイルを選択するダイアログが開き、表示する標高データを選択することができます。ファイルは同時に、縦横3面の範囲、最大で9面までを選択→表示できます。
次にダイアログが開き、下のパラメーターを設定します。
地図画像パス 図画像のCD-ROMが入っているドライブを指定します。
画像幅 立体図に貼り付ける前に、CD-ROMの画像から地図面のみ切り出します。このときの切り出し幅を画素数で指定します。
入力画像とほぼ同じ(4500)程度にしておくと記号などもつぶれずに表示されます。それほどの精度が要求されない場合はもっと小さな値(たとえば1000〜2000ほど)でも十分です。

選択した標高データに対応する地図画像ファイルは、上で指定した『地図画像パス』
のCD-ROMに含まれている必要があります。
250m/1km 数値地図貼り付け

250m、1kmなど間隔の違うデータを混在させて選択することはできません
立体的に表示された20万の標高データの上に地図画像を重ねます。
ファイルの選択やパラメーターの設定方法などは上の『50m』と同じです。
表示パラメーター 下記のような立体表示のパラメーターを設定します。
設定するには各ボックスに数値を直接、入力してもよく、また、横のスライダー・バーを動かして変更することもできます。
方位角 視点から注視点を見る方位を0〜360度の間で設定します。真東が0゚に当たります。
仰角 視点から注視点を見下ろす角度を0〜90゚の間で指定します。0゚=水平、90゚=真上に当たります。
視野角 視野の広さを180度までの角度で指定します。
視点距離 視点から注視点への距離。
Z拡大率 データを垂直方向に拡大、または縮小して表示できます。拡大率のデフォルト地は.0です。
注視点X 注視点は表示するデータの範囲内にあって、視点から見つめている点です。ここでは注視点の位置を選択した測量座標系における座標で指定します。デフォルトはデータ存在範囲の中心になっています。
注視点Y
注視点Z
太陽方位 データ中心部から見た太陽位置を0〜360度の方位で設定します(真東=0°)
太陽高度 0〜90°の間で指定します。0=水平、90=真上に当たります
表示間隔 デフォルトは1→すべての点を表示します。2以上の場合は格子の間隔を飛ばしながら荒い表示を行います
色分け 地形を標高、傾斜、斜面方位のどれに基づいて色分けするかを選択します

パラメーターを変更するとインデックス上に描かれた視点、注視点、太陽の平面位置が変更され、また視野に入るエリアが線で表示されます。
■表示■
一次メッシュリスト 日本全国の一次メッシュのマップを表示します。地図名の上で左クリックすると、図郭のメッシュ番号が表示されます。利用したい地域のメッシュ番号を調べるのに利用できます。。。
スクリーン・サイズ変更 データ表示を行った後でPixTOPOのウィンドーをリサイズしても、画面はすぐには書き換えられません。新しいスクリーンのサイズに合わせてデータを書き直すには、この『スクリーン・サイズ変更』を実行します。
カラー・マップ


平滑化無

平滑化有
地形データの平面図、立体図などが表示されているとき、標高(または傾斜、斜面方位)の凡例をダイアログに表します。。
読み込み−凡例定義(境界値と色)をファイルから読み込みます。
書き込み−現在表示されている凡例定義をファイルセーブします。
平滑化−これをONにしておくと表示に当たって各画素の色が高さの値で内挿されます。色合いがなめらかになりますが、描画時間は長くかかります。
凡例表示 標高データが平面/立体表示されている状態で凡例を画面上に表示します。メニューから『凡例表示』を選んだ後で、スクリーン上で凡例を描く長方形を指定してください。
マウスの左クリックで長方形のコーナーを指定、右クリックでキャンセルします。
凡例移動 すでに表示されている凡例ボックスを移動します。マウス左クリックで新しい位置を指定してください。
凡例消去 表示されている凡例ボックスを消去します
■数値地図変換■
標高→DXF

『標高→DXF』の変換を行うためには、はじめに測量座標系を選択しておく必要があります。
標高の数値地図データを、CADの標準フォーマットであるDXF形式に変換します。ファイルを選択するダイアログが開き、変換する標高データ(MEM、SEM、TEMファイル)を選択します。
以下のパラメーターを設定することができます。
出力ファイル 出力ファイル名を設定します。
Z拡大率 Z座標を強調したデータとして出力することができます。デフォルト=1.0.
画層名 図形データが属する任意の画層名を指定します。
格子間隔 標高データの全メッシュではなく、一定間隔で飛ばしながら出力することもできます。1の場合飛ばさずに全メッシュを出力します。
色分け 凡例に応じて画層の表示色を変えたい場合はONにしてください

データはAutoCADの3DFACEエンティティーとして記録されます。すべてのデータは上で指定した画層に属する三角形となります。
上は出力したDXFファイルをTurboCADで表示した例。
火山→DXF

『火山→DXF』の変換を行うためには、はじめに測量座標系を選択しておく必要があります。
数値地図10mメッシュ(火山標高)のデータをDXF形式に変換します。ダイアログが開き、変換する標高データ(LEMファイル)を選択します。
以下のパラメーターを設定することができます。
出力ファイル 出力ファイル名を設定します。
Z拡大率 Z座標を強調したデータとして出力することができます。デフォルト=1.0.
画層名 図形データが属する任意の画層名を指定します。
分割(縦) DXFファイルの容量を小さくするため、いくつかに分割出力することができます。分割されたDXFにはmiyake_0001.dxfのように数字のサフィックスが付きます。ファイルは縦方向に帯状に分割されます。1の場合は分割しません。
色分け 凡例に応じて画層の表示色を変えたい場合はONにしてください
格子間隔の指定はできません。

データはAutoCADの3DFACEエンティティーとして記録されます。すべてのデータは上で指定した画層に属する三角形となります。

【注意】このデータは、標高データ本体であるLEMと、ヘッダー情報であるCSVのふたつからなり、それぞれLEMとCSVと言うディレクトリーに分かれて納められています。ファイルをハード・ディスクなどにコピーする場合は、この相対的な位置関係を保つことが必要です。

例:ディレクトリー:c:\data\kazanにコピーする場合、*.lemファイルはc:\data\kazan\lem、*.csvファイルはc:\data\kazan\csvに保存してください。

ファイル・ダイアログより、lemファイルを選択してください。選択できるのはひとつだけです。複数のファイルをまとめて変換することはできません。
■パラメーター・ファイル■
凡例 PixTOPOの凡例ファイルはp4dという拡張子を持つテキストファイルであり、以下の項目が任意の順で並んでいます。
ZONES 色分けクラス数
COLOR 各クラスの表示色をRGB値で指定します。クラス番号、R値(0〜255)、G値(0〜255)、B値(0〜255)をコンマ(,)で区切って並べます。
ZONE 各クラスの上限の境界値を指定します。クラス番号、境界値をコンマ(,)で区切って並べます。
BACKCOLOR 図形データが属する任意の画層名を指定します。
SEACOLOR 凡例に応じて画層の表示色を変えたい場合はONにしてください
#で始まる行はコメントであり、読み込まれません。以下に実際の凡例ファイルの例を挙げます。
# PixTOPO ColorMAP: Zone Definition
#
ZONES,18
#
COLOR,0,89,157,86
COLOR,1,105,166,96
COLOR,2,120,175,106
COLOR,3,136,185,117
COLOR,4,152,194,127
COLOR,5,167,203,137
COLOR,6,183,212,147
COLOR,7,199,222,158
COLOR,8,214,231,168
COLOR,9,230,240,178
COLOR,10,244,223,158
COLOR,11,255,211,143
COLOR,12,242,195,124
COLOR,13,236,188,116
COLOR,14,231,180,109
COLOR,15,216,165,97
COLOR,16,201,151,84
COLOR,17,187,136,72
#
ZONE,0,44.2
ZONE,1,80.4
ZONE,2,116.6
ZONE,3,152.8
ZONE,4,189.1
ZONE,5,225.3
ZONE,6,261.5
ZONE,7,297.7
ZONE,8,334.0
ZONE,9,370.2
ZONE,10,406.4
ZONE,11,442.6
ZONE,12,478.8
ZONE,13,515.1
ZONE,14,551.3
ZONE,15,587.5
ZONE,16,623.7
#
BACKCOLOR,22,72,72
#
SEACOLOR,176,247,237
#
# END
上の例では、たとえばクラス5は標高189.1〜225.3mの間であり、RGB値(167、203、137)で描かれることを表しています。


PixTOPO